RimWorld 1.3 mods status

Here’s a post about the availability of RimWorld 1.3 mods and my plans for 1.3 mods.

  1. Ugh You Got Me – available.
  2. Sometimes Raids Go Wrong – available.

My other mods have been taken over by other maintainers and may not be available for 1.3 yet.

Note that, because RimWorld supports multi-versioning, you can use the latest download in previous versions of RimWorld as far back as 1.0 if you still have old saved games that you want to play.

Leave a Reply

Your email address will not be published.